PDA

توجه ! این یک نسخه آرشیو شده میباشد و در این حالت شما عکسی را مشاهده نمیکنید برای مشاهده کامل متن و عکسها بر روی لینک مقابل کلیک کنید : Python براي uiq و uiq3



solsoln
04-07-2008, 00:17
سلام به تمام كاربران بخش uiq
من بخش uiq جستجو كردم و اين نرم افزارو پيدا نكردم براي همين اين تاپيك رو باز كردم
و همچنين عذرخواهي ميكنم كه اين برنامه را تو سايت اپلود نكردم چون حجم برنامه زياده و با اينترنت دايل اپ مشكل بود ، از مديران سايت خواهش ميكنم اين برنامه را اپلود كنيد

The Python programming language for UIQ 2.1 and UIQ 3 mobile phones

اين برنامه مانند Python در سري 60 هست براي uiq و uiq3
دانلود (http://sourceforge.net/project/showfiles.php?group_id=192058) برنامه و اسكريپت

raminrt_2006
04-07-2008, 16:11
دوستان کسي تست کرده؟

mohammad_1ta
04-07-2008, 22:38
سلام،
تو اون لینک من چندتاشو که واسه UIQ 3 بود رو دانلود کردم و براتون قرار میدم
(فقط نمیدونم کدوم اصله کاریه :mdr: ولی به احتمال زیاد PythonForUIQ_UIQ30_selfsigned.SIS هست، چون دانلودش بیشتر از بقیه بود)

solsoln
04-07-2008, 22:56
دوستان کسي تست کرده؟
بله من اين برنامه رو گوشيم تست كردم


تو اون لینک من چندتاشو که واسه UIQ 3 بود رو دانلود کردم و براتون قرار میدم
(فقط نمیدونم کدوم اصله کاریه ولی به احتمال زیاد PythonForUIQ_UIQ30_selfsigned.SIS هست، چون دانلودش بیشتر از بقیه بود)


mohammad_1ta عزيز متشكرم كه فايل هاي UIQ3 را اپلود كردي

براي UIQ3 فايل PythonForUIQ_UIQ30_selfsigned.SIS را نصب كنيد سپس PythonScriptShell_UIQ30_selfsigned.SIS

و براي UIQ2 PythonForUIQ_UIQ20_selfsigned.SIS و سپس PythonScriptShell_UIQ20_selfsigned.SIS

raminrt_2006
05-07-2008, 13:54
من که کپاک فاطي کردم.از اون فايل هايي که محمد جان آپلود کرده کدوما رو بايد واسهp990 دانلود کرد?

solsoln
05-07-2008, 18:58
من که کپاک فاطي کردم.از اون فايل هايي که محمد جان آپلود کرده کدوما رو بايد واسهp990 دانلود کرد?
p990 uiq3 هست و شما براي UIQ3 فايل PythonForUIQ_UIQ30_selfsigned.SIS را نصب كنيد سپس PythonScriptShell_UIQ30_selfsigned.SIS

raminrt_2006
05-07-2008, 20:59
پس بقيه که واسه uiq3 هست چي؟اونا چي هستند؟

solsoln
06-07-2008, 08:27
پس بقيه که واسه uiq3 هست چي؟اونا چي هستند؟
باقيش همون قبلي ها اما فايل هاي sign نشده هستند ، يكيشم فايل pdf توضيحات و اموزش برنامه
اگه كمي روي نام فايل ها دقت كني كاملا مشخصه

saeed virus
06-07-2008, 13:24
واسه نوکیا این برنامه اسکریپتهای بسیار جالبی داره. میخواستم بپرسم واسه p990 بغیر از این چندتا دیگه اسکریپتهای جالبتری نداره؟

solsoln
07-07-2008, 19:35
اين برنامه Python 2.2.2 براي سري 60 هستش كه به uiq پورت شده و بعضي از اسكريپت ها و كد هاي s60 را اجرا مي كنه ولي هنوز كمي باگ داره و انچه كه من از توضيحاتش فهميدم اي بود كه بعضي چيزا مثل contacts location messaging sysinfo camera ساپرت نميشه

براي اطلاعات بيشتر و همچنين نحوه نصب برنامه و استفاده از ان متن زير را بخوانيد


Installation to emulator
------------------------

Unzip the "sdk_files.zip" to your UIQ "<UIQ_ROOT>\epoc" root folder, make sure
that the folders align with your SDK installation.

Usage in emulator
-----------------

Start the "Python" application from the emulator menu. This launches the script
"default.py" found from:

"<UIQ_ROOT>\epoc32\release\wins\udeb\z\system\apps\PYTHON"

For testing other features and functionalities, replace "default.py" with your
own script, rename it as "default.py" as the script search path is hard coded.

The current "default.py" included in the distribution is a simple script
demonstrating the application menu and text widget.



Supported features
------------------

NOTE: No formal testing has been done for this release, the below list acts
therefore only as a guideline.

For the supported features, please see the screenshots illustrating the current
funtionality.

The following extensions are supported:

calendar (does not show the entries in agenda application)
e32db
graphics ("Image.open" is not supported)
inbox
audio (not supported currently in UIQ21)
socket
telephone
zlib

The Python standard library support is as in Python for S60 1.3.18 version,
refer to "API_Reference_for_Python" available from:

http://sourceforge.net/project/showfiles.php?group_id=154155

The following extensions are not currently supported:

contacts
location
messaging
sysinfo
camera

Native UI widgets, except "appuifw.Text" and the application menu, are not
supported.